-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
                         AUSCERT Security Bulletin

                               ASB-2017.0048
         Security Advisory: Oracle Financial Services Applications
                               20 April 2017

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:              Oracle Financial Services Applications
Operating System:     Windows
                      UNIX variants (UNIX, Linux, OSX)
Impact/Access:        Execute Arbitrary Code/Commands -- Remote/Unauthenticated      
                      Modify Arbitrary Files          -- Remote with User Interaction
                      Denial of Service               -- Existing Account            
Resolution:           Patch/Upgrade
CVE Names:            CVE-2017-5638 CVE-2017-3535 CVE-2017-3534
                      CVE-2017-3496 CVE-2017-3495 CVE-2017-3494
                      CVE-2017-3493 CVE-2017-3492 CVE-2017-3491
                      CVE-2017-3490 CVE-2017-3489 CVE-2017-3488
                      CVE-2017-3487 CVE-2017-3485 CVE-2017-3484
                      CVE-2017-3483 CVE-2017-3482 CVE-2017-3481
                      CVE-2017-3480 CVE-2017-3479 CVE-2017-3478
                      CVE-2017-3477 CVE-2017-3476 CVE-2017-3475
                      CVE-2017-3473 CVE-2017-3472 CVE-2017-3471
                      CVE-2017-3288 CVE-2016-0635 
Member content until: Saturday, May 20 2017
Reference:            ASB-2017.0038
                      ASB-2017.0022.2
                      ASB-2017.0005
                      ESB-2017.0923
                      ESB-2017.0834
                      ESB-2017.0821

OVERVIEW

        Multiple vulnerabilities have been identified in the following 
        components of Oracle Financial Services Applications:
        
        Oracle Financial Services Analytical Applications Infrastructure, 
        version(s) 7.3.3, 7.3.4, 7.3.5
        Oracle Financial Services Asset Liability Management, version(s) 
        6.0.0, 6.1.0, 6.1.1, 8.0.1, 8.0.2, 8.0.3, 8.0.4
        Oracle Financial Services Basel Regulatory Capital Basic, version(s)
          6.1.2, 6.1.3, 8.0.2, 8.0.3
        Oracle Financial Services Basel Regulatory Capital Internal Ratings
        Based Approach, version(s) 6.1.2, 6.1.3, 8.0.2, 8.0.3
        Oracle Financial Services Data Foundation, version(s) 8.0.1, 8.0.2,
        8.0.3, 8.0.4
        Oracle Financial Services Data Integration Hub, version(s) 8.0.1, 
        8.0.2, 8.0.3, 8.0.4
        Oracle Financial Services Enterprise Financial Performance 
        Analytics, version(s) 8.0.0 to 8.0.4
        Oracle Financial Services Funds Transfer Pricing, version(s) 6.0.0,
        6.1.0, 6.1.1, 8.0.1, 8.0.2, 8.0.3, 8.0.4
        Oracle Financial Services Hedge Management and IFRS Valuations, 
        version(s) 6.1.1, 8.0.1, 8.0.2, 8.0.3, 8.0.4
        Oracle Financial Services Institutional Performance Analytics, 
        version(s) 8.0.0 to 8.0.4
        Oracle Financial Services Liquidity Risk Management, version(s) 
        8.0.1, 8.0.2, 8.0.4
        Oracle Financial Services Loan Loss Forecasting and Provisioning, 
        version(s) 1.5.0, 1.5.1, 8.0.1, 8.0.2, 8.0.3, 8.0.4
        Oracle Financial Services Pricing Management/Transfer Pricing 
        Component, version(s) 8.0.0 to 8.0.4
        Oracle Financial Services Profitability Management, version(s) 
        6.0.0, 6.1.0, 6.1.1, 8.0.1, 8.0.2, 8.0.3, 8.0.4
        Oracle Financial Services Reconciliation Framework, version(s) 
        8.0.0, 8.0.1, 8.0.2
        Oracle Financial Services Retail Customer Analytics, version(s) 
        8.0.0 to 8.0.3
        Oracle Financial Services Retail Performance Analytics, version(s) 
        8.0.0 to 8.0.4
        Oracle FLEXCUBE Direct Banking, version(s) 12.0.2, 12.0.3
        Oracle FLEXCUBE Enterprise Limits and Collateral Management, 
        version(s) 12.0.0, 12.0.1, 12.1.0
        Oracle FLEXCUBE Investor Servicing, version(s) 12.0.1, 12.0.2, 
        12.0.3, 12.0.4, 12.1.0, 12.2.0, 12.3.0
        Oracle FLEXCUBE Private Banking, version(s) 2.0.0, 2.0.1, 2.2.0.1, 
        12.0.0, 12.0.1, 12.0.2, 12.0.3, 12.1.0
        Oracle FLEXCUBE Universal Banking, version(s) 11.3.0, 11.4.0, 
        12.0.0, 12.0.1, 12.0.2, 12.0.3, 12.1.0, 12.2.0, 12.3.0
        Oracle Insurance Data Foundation, version(s) 8.0.1, 8.0.2, 8.0.3, 
        8.0.4. [1]


IMPACT

        The vendor has provided the following information:
        
        "CVE-2017-5638 10.0 AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
        Easily exploitable vulnerability allows unauthenticated attacker 
        with network access via HTTP to compromise Oracle Financial 
        Services. While the vulnerability is in Oracle Financial Services 
        Enterprise Financial Performance Analytics, attacks may 
        significantly impact additional products. Successful attacks of this
        vulnerability can result in takeover of Oracle Financial Services.
        
        CVE-2016-0635 8.8 AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle Communications Network
        Integrity. Successful attacks of this vulnerability can result in 
        takeover of Oracle Communications Network Integrity.
        
        CVE-2017-3493 8.5 AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:L
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Enterprise 
        Limits and Collateral Management. While the vulnerability is in 
        Oracle FLEXCUBE Enterprise Limits and Collateral Management, attacks
        may significantly impact additional products. Successful attacks of
        this vulnerability can result in unauthorized access to critical 
        data or complete access to all Oracle FLEXCUBE Enterprise Limits and
        Collateral Management accessible data and unauthorized ability to 
        cause a partial denial of service (partial DOS) of Oracle FLEXCUBE 
        Enterprise Limits and Collateral Management.
        
        CVE-2017-3472 8.1 AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized creation, deletion or modification access to critical 
        data or all Oracle FLEXCUBE Private Banking accessible data as well
        as unauthorized access to critical data or complete access to all 
        Oracle FLEXCUBE Private Banking accessible data.
        
        CVE-2017-3476 7.1 AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized access to critical data or complete access to all 
        Oracle FLEXCUBE Private Banking accessible data as well as 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Private Banking accessible data.
        
        CVE-2017-3485 6.8 AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:H
        Difficult to exploit vulnerability allows low privileged attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Universal
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized creation, deletion or modification access to critical 
        data or all Oracle FLEXCUBE Universal Banking accessible data and 
        unauthorized ability to cause a hang or frequently repeatable crash
        (complete DOS) of Oracle FLEXCUBE Universal Banking.
        
        CVE-2017-3491 6.5 AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Enterprise 
        Limits and Collateral Management. Successful attacks of this 
        vulnerability can result in unauthorized access to critical data or
        complete access to all Oracle FLEXCUBE Enterprise Limits and 
        Collateral Management accessible data.
        
        CVE-2017-3488 6.5 AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Investor 
        Servicing. Successful attacks of this vulnerability can result in 
        unauthorized creation, deletion or modification access to critical 
        data or all Oracle FLEXCUBE Investor Servicing accessible data.
        
        CVE-2017-3534 6.5 AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Universal 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized access to critical data or complete access to all 
        Oracle FLEXCUBE Universal Banking accessible data.
        
        CVE-2017-3496 6.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
        Easily exploitable vulnerability allows unauthenticated attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE 
        Enterprise Limits and Collateral Management. Successful attacks 
        require human interaction from a person other than the attacker and
        while the vulnerability is in Oracle FLEXCUBE Enterprise Limits and
        Collateral Management, attacks may significantly impact additional 
        products. Successful attacks of this vulnerability can result in 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Enterprise Limits and Collateral Management accessible data
        as well as unauthorized read access to a subset of Oracle FLEXCUBE 
        Enterprise Limits and Collateral Management accessible data.
        
        CVE-2017-3492 5.4 AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Enterprise 
        Limits and Collateral Management. Successful attacks of this 
        vulnerability can result in unauthorized update, insert or delete 
        access to some of Oracle FLEXCUBE Enterprise Limits and Collateral 
        Management accessible data as well as unauthorized read access to a
        subset of Oracle FLEXCUBE Enterprise Limits and Collateral 
        Management accessible data.
        
        CVE-2017-3484 5.4 AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Enterprise 
        Limits and Collateral Management. Successful attacks of this 
        vulnerability can result in unauthorized update, insert or delete 
        access to some of Oracle FLEXCUBE Enterprise Limits and Collateral 
        Management accessible data as well as unauthorized read access to a
        subset of Oracle FLEXCUBE Enterprise Limits and Collateral 
        Management accessible data.
        
        CVE-2017-3489 5.4 AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Investor 
        Servicing. Successful attacks of this vulnerability can result in 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Investor Servicing accessible data as well as unauthorized
        read access to a subset of Oracle FLEXCUBE Investor Servicing 
        accessible data.
        
        CVE-2017-3288 5.4 AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Investor 
        Servicing. Successful attacks of this vulnerability can result in 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Investor Servicing accessible data as well as unauthorized
        read access to a subset of Oracle FLEXCUBE Investor Servicing 
        accessible data.
        
        CVE-2017-3478 5.4 AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Private Banking accessible data as well as unauthorized 
        read access to a subset of Oracle FLEXCUBE Private Banking 
        accessible data.
        
        CVE-2017-3479 5.4 AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Private Banking accessible data and unauthorized ability to
        cause a partial denial of service (partial DOS) of Oracle FLEXCUBE 
        Private Banking.
        
        CVE-2017-3482 5.4 AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Universal 
        Banking. Successful attacks require human interaction from a person
        other than the attacker and while the vulnerability is in Oracle 
        FLEXCUBE Universal Banking, attacks may significantly impact 
        additional products. Successful attacks of this vulnerability can 
        result in unauthorized update, insert or delete access to some of 
        Oracle FLEXCUBE Universal Banking accessible data as well as 
        unauthorized read access to a subset of Oracle FLEXCUBE Universal 
        Banking accessible data.
        
        CVE-2017-3475 5.0 AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. While the vulnerability is in Oracle FLEXCUBE Private 
        Banking, attacks may significantly impact additional products. 
        Successful attacks of this vulnerability can result in unauthorized
        ability to cause a partial denial of service (partial DOS) of Oracle
        FLEXCUBE Private Banking.
        
        CVE-2017-3495 4.7 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
        Easily exploitable vulnerability allows unauthenticated attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Direct 
        Banking. Successful attacks require human interaction from a person
        other than the attacker and while the vulnerability is in Oracle 
        FLEXCUBE Direct Banking, attacks may significantly impact additional
        products. Successful attacks of this vulnerability can result in 
        unauthorized read access to a subset of Oracle FLEXCUBE Direct 
        Banking accessible data.
        
        CVE-2017-3471 4.7 AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
        Easily exploitable vulnerability allows unauthenticated attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. Successful attacks require human interaction from a person
        other than the attacker and while the vulnerability is in Oracle 
        FLEXCUBE Private Banking, attacks may significantly impact 
        additional products. Successful attacks of this vulnerability can 
        result in unauthorized update, insert or delete access to some of 
        Oracle FLEXCUBE Private Banking accessible data.
        
        CVE-2017-3480 4.7 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
        Easily exploitable vulnerability allows unauthenticated attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Universal
        Banking. Successful attacks require human interaction from a person
        other than the attacker and while the vulnerability is in Oracle 
        FLEXCUBE Universal Banking, attacks may significantly impact 
        additional products. Successful attacks of this vulnerability can 
        result in unauthorized read access to a subset of Oracle FLEXCUBE 
        Universal Banking accessible data.
        
        CVE-2017-3535 4.7 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
        Easily exploitable vulnerability allows unauthenticated attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Universal
        Banking. Successful attacks require human interaction from a person
        other than the attacker and while the vulnerability is in Oracle 
        FLEXCUBE Universal Banking, attacks may significantly impact 
        additional products. Successful attacks of this vulnerability can 
        result in unauthorized read access to a subset of Oracle FLEXCUBE 
        Universal Banking accessible data.
        
        CVE-2017-3494 4.7 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
        Easily exploitable vulnerability allows unauthenticated attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Universal
        Banking. Successful attacks require human interaction from a person
        other than the attacker and while the vulnerability is in Oracle 
        FLEXCUBE Universal Banking, attacks may significantly impact 
        additional products. Successful attacks of this vulnerability can 
        result in unauthorized read access to a subset of Oracle FLEXCUBE 
        Universal Banking accessible data.
        
        CVE-2017-3483 4.4 AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
        Easily exploitable vulnerability allows high privileged attacker 
        with logon to the infrastructure where Oracle FLEXCUBE Enterprise 
        Limits and Collateral Management executes to compromise Oracle 
        FLEXCUBE Enterprise Limits and Collateral Management. Successful 
        attacks of this vulnerability can result in unauthorized access to 
        critical data or complete access to all Oracle FLEXCUBE Enterprise 
        Limits and Collateral Management accessible data.
        
        CVE-2017-3473 4.3 AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized read access to a subset of Oracle FLEXCUBE Private 
        Banking accessible data.
        
        CVE-2017-3481 4.3 AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
        Easily exploitable vulnerability allows low privileged attacker with
        network access via HTTP to compromise Oracle FLEXCUBE Universal 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized ability to cause a partial denial of service (partial 
        DOS) of Oracle FLEXCUBE Universal Banking.
        
        CVE-2017-3477 4.2 AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
        Difficult to exploit vulnerability allows low privileged attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Private 
        Banking. Successful attacks of this vulnerability can result in 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Private Banking accessible data as well as unauthorized 
        read access to a subset of Oracle FLEXCUBE Private Banking 
        accessible data.
        
        CVE-2017-3490 3.1 AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
        Difficult to exploit vulnerability allows low privileged attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE 
        Enterprise Limits and Collateral Management. Successful attacks of 
        this vulnerability can result in unauthorized read access to a 
        subset of Oracle FLEXCUBE Enterprise Limits and Collateral 
        Management accessible data.
        
        CVE-2017-3487 3.1 AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
        Difficult to exploit vulnerability allows low privileged attacker 
        with network access via HTTP to compromise Oracle FLEXCUBE Investor
        Servicing. Successful attacks of this vulnerability can result in 
        unauthorized update, insert or delete access to some of Oracle 
        FLEXCUBE Investor Servicing accessible data." [2]


MITIGATION

        Oracle states:
        
        "Due to the threat posed by a successful attack, Oracle strongly 
        recommends that customers apply CPU fixes as soon as possible. Until
        you apply the CPU fixes, it may be possible to reduce the risk of 
        successful attack by blocking network protocols required by an 
        attack. For attacks that require certain privileges or access to 
        certain packages, removing the privileges or the ability to access 
        the packages from users that do not need the privileges may help 
        reduce the risk of successful attack. Both approaches may break 
        application functionality, so Oracle strongly recommends that 
        customers test changes on non-production systems. Neither approach 
        should be considered a long-term solution as neither corrects the 
        underlying problem." [1]


REFERENCES

        [1] Oracle Critical Patch Update Advisory - April 2017
            http://www.oracle.com/technetwork/security-advisory/cpuapr2017-3236618.html

        [2] Text Form of Oracle Critical Patch Update - April 2017 Risk
            Matrices
            https://www.oracle.com/technetwork/topics/security/cpuapr2017verbose-3236619.html

AusCERT has made every effort to ensure that the information contained
in this document is accurate.  However, the decision to use the information
described is the responsibility of each user or organisation. The decision to
follow or act on information or advice contained in this security bulletin is
the responsibility of each user or organisation, and should be considered in
accordance with your organisation's site policies and procedures. AusCERT
takes no responsibility for consequences which may arise from following or
acting on information or advice contained in this security bulletin.

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours 
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWPhDxIx+lLeg9Ub1AQjcwQ//VTIVvMmjqB3wSfk89Tl5sAi2y2rJ7WAi
/rWLe2+sI75kq9RXjqZGqZ3B0e7QKy/3oQo1wHUvH3Z5f7R6XgJ4/VkB3orx3brJ
X/iR5ItTvOSdo2KCykYLV9WLmwzqZSc2YGcWrUfPXGciXnP3sLnFLSBbkVyml9es
YyafK9RWEba+EXXWBHf0QtPh44ypn3BxJmf3YSF27SQ05p5VYpkpfCSEGw/urrvD
I4SOvxOfRgU74+AMyS+GW17BgHz90HC/VkGT508yWLsGP0j6xKG5M9UKUPiaGLex
aYNQtsJWtltJiybIox1QihF7CZyKNAaS3hUtpPUdAB/tewH4tROBtlGrWNdYfoQW
EaA+DT+ofwTXUXX4I4GCkSafN+a2JH/TzhIDx/uxUPqeur4qmhmA/R/DDYIb5fcq
0Xo1tZfWfq3ycwF7ov/8Lo1e0nN7k7v63XF0djXp5lB1AmG5LFsGlAiO7WxXM95n
0G2P5wkedeWYJAs8a1tzMe/gss5niPnFQQ8gSMqh9das58bB/dZJqhRLcLrKreML
uHOUZXNnyOBk3eJwSJVznIk5GcbAo/ExyzYoizGftqi0biVWHuaJYq5WuFr7ZEeZ
v1iowsyKuC3VIuOWNawuwVqY09CbRetl73OIee8HTDX+k719QOOwE4QEmtDyX/LG
kHawaHB21Qs=
=0v8w
-----END PGP SIGNATURE-----