Hash: SHA1

             AUSCERT External Security Bulletin Redistribution

                       ESB-2006.0138 -- [UNIX/Linux]
         PostgreSQL versions 8.1.3, 8.0.7, 7.4.12 and 7.3.14 have
                 been released fixing two security issues
                             17 February 2006


        AusCERT Security Bulletin Summary

Product:           PostgreSQL 8.1.0-8.1.2
Publisher:         PostgreSQL Global Development Group
Operating System:  UNIX variants (UNIX, Linux, OSX)
Impact:            Increased Privileges
                   Denial of Service
Access:            Existing Account
CVE Names:         CVE-2006-0678 CVE-2006-0553

Original Bulletin: 

- --------------------------BEGIN INCLUDED TEXT--------------------

PostgreSQL versions 8.1.3, 8.0.7, 7.4.12 and 7.3.14 have been released 
fixing two security issues.

Details of vulnerability 1
- --------------------------
Vulnerability type: Escalation of privileges
Remotely exploitable: No (requires valid login)

Affected versions: PostgreSQL 8.1.0-8.1.2
Fixed versions: PostgreSQL 8.1.3

Affected platforms: All

CVE: CVE-2006-0553 (http://cve.mitre.org/cgi-bin/cvename.cgi?name=2006-0553)

Vulnerability description
- -------------------------
By issuing SET ROLE with a specially crafted argument, it is possible 
for any logged-in database user to acquire the privileges of any other 
database user, including superusers. Database superuser status allows 
access to the machine's filesystem and hence might be used to mount 
remote attacks against the rest of the server's operating system.
SET ROLE is not available in PostgreSQL prior to version 8.1.

Details of vulnerability 2
- --------------------------
Vulnerability type: Denial of service
Remotely exploitable: No (requires valid login)

Affected versions: PostgreSQL 8.0.0-8.0.6, 7.4.0-7.4.11, 7.3.0-7.3.13
Fixed versions: PostgreSQL 8.0.7, 7.4.12, 7.3.14

Affected platforms: All

CVE: CVE-2006-0678 (http://cve.mitre.org/cgi-bin/cvename.cgi?name=2006-0678)

Vulnerability description
- -------------------------
A similar issue exists in SET SESSION AUTHORIZATION. This variant cannot 
be exploited for privilege escalation, because one must already be 
However, if the server has been compiled with Asserts enabled (which is 
not the default), then it is possible to trigger an Assert failure 
before the privilege check is reached.  This would cause a momentary 
denial of service to other database users.

- --------
Upgrade to version 8.1.3, 8.0.7, 7.4.12 or 7.3.14 respectively, 
available from http://www.postgresql.org/ftp/ in both source and binary 

Mitigating factors
- ------------------
A valid login to the database is required before any of these 
vulnerabilities can be exploited.

PostgreSQL will not allow execution as "root" on Unix or with 
administrator permissions on Windows, which limits the exposure of other 
parts of the system.

- --------
2006-02-03 - Vulnerability reported
2006-02-03 - Initial stop-gap patch created
2006-02-12 - Patch applied to main tree and new versions packaged
2006-02-14 - New versions announced

- -------
The PostgreSQL Global Development Group thanks Akio Ishida for reporting 
this vulnerability.

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:


If you believe that your computer system has been compromised or attacked in 
any way, we encourage you to let us know by completing the secure National IT 
Incident Reporting Form at:


Australian Computer Emergency Response Team
The University of Queensland
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.

Comment: http://www.auscert.org.au/render.html?it=1967