-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

===========================================================================
             AUSCERT External Security Bulletin Redistribution

                               ESB-2018.0167
Security Bulletin: IBM FileNet Content Manager, IBM Content Foundation, and
     IBM Case Foundation are affected by the ability to execute remote
        attacker's arbitrary code on a target machine vulnerability
                              16 January 2018

===========================================================================

        AusCERT Security Bulletin Summary
        ---------------------------------

Product:           IBM FileNet Content Manager
Publisher:         IBM
Operating System:  AIX
                   HP-UX
                   Linux variants
                   Solaris
                   Windows
Impact/Access:     Execute Arbitrary Code/Commands -- Remote/Unauthenticated
Resolution:        Patch/Upgrade
CVE Names:         CVE-2016-1000031  

Reference:         ESB-2018.0125
                   ESB-2017.3098

Original Bulletin: 
   http://www.ibm.com/support/docview.wss?uid=swg22010868

- --------------------------BEGIN INCLUDED TEXT--------------------

Security Bulletin: IBM FileNet Content Manager, IBM Content Foundation, and IBM
Case Foundation are affected by the ability to execute remote attacker's
arbitrary code on a target machine vulnerability

Document information

More support for: FileNet Content Manager
Content Platform Engine

Software version: 5.2.1, 5.5.0

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 2010868

Modified date: 15 January 2018

Security Bulletin

Summary

IBM FileNet Content Manager, IBM Content Foundation and IBM Case Foundation has
addressed the following security vulnerability.

Ability to execute remote attacker's arbitrary code on a target machine by
leveraging the untrusted data in DiskFileItem class of Apache Commons
FileUpload library. The affected "Apache Commons FileUpload" has been upgraded
to the fixed version v1.3.3.

For more information please refer to the X-Force database entries referenced
below.

Vulnerability Details

CVEID: CVE-2016-1000031
DESCRIPTION: Apache Commons FileUpload, as used in Novell NetIQ Sentinel and
other products, could allow a remote attacker to execute arbitrary code on the
system, caused by deserialization of untrusted data in DiskFileItem class of
the FileUpload library. A remote attacker could exploit this vulnerability to
execute arbitrary code under the context of the current process.
CVSS Base Score: 9.8
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/
117957 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

IBM FileNet Content Manager 5.2.1, 5.5.0
IBM Content Foundation 5.2.1, 5.5.0
IBM Case Foundation 5.2.1, 5.3.0

Remediation/Fixes

To address this vulnerability install one of the fixes listed below to upgrade
to Apache Commons FileUpload v1.3.3 or higher.

+-----------------------------------+-------+----------+---------------------------------------------------+
|Product                            |VRMF   |APAR      |Remediation/First Fix                              |
+-----------------------------------+-------+----------+---------------------------------------------------+
|FileNet Content Manager / Content  |5.2.1  |PJ45055   |5.2.1.7-P8CPE-ALL-LA008 - 1/15/2018                |
|Foundation                         |5.5.0  |PJ45055   |5.5.0.0-P8CPE-ALL-LA001 - 1/15/2018                |
+-----------------------------------+-------+----------+---------------------------------------------------+
|Case Foundation                    |5.2.1  |PJ45055   |5.2.1.7-P8CPE-ALL-LA008 - 1/15/2018                |
|                                   |5.3.0  |PJ45055   |5.5.0.0-P8CPE-ALL-LA001 - 1/15/2018                |
+-----------------------------------+-------+----------+---------------------------------------------------+

In the above table, the APAR links will provide more information about the fix

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

Subscribe to My Notifications to be notified of important product support
alerts like this.

Important note

IBM strongly suggests that all System z customers be subscribed to the System z
Security Portal to receive the latest critical System z security and integrity
service. If you are not subscribed, see the instructions on the System z
Security web site. Security and integrity APARs and associated fixes will be
posted to this portal. IBM suggests reviewing the CVSS scores and applying all
security or integrity fixes as soon as possible to minimize any potential risk.

References

Complete CVSS v3 Guide
On-line Calculator v3


Related information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

15 January 2018: Original Version Published

*The CVSS Environment Score is customer environment specific and will
ultimately impact the Overall CVSS Score. Customers can evaluate the impact of
this vulnerability in their environments by accessing the links in the
Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the
Common Vulnerability Scoring System (CVSS) is an "industry open standard
designed to convey vulnerability severity and help to determine urgency and
priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF
ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY
ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

                          Cross reference information
       Segment           Product        Component     Platform Version  Edition
 Enterprise Content   Case          Process Engine             5.2.1,
     Management       Foundation                               5.3.0
 Enterprise Content   Content       Content Platform           5.5.0,
     Management       Foundation    Engine                     5.2.1

- --------------------------END INCLUDED TEXT--------------------

You have received this e-mail bulletin as a result of your organisation's
registration with AusCERT. The mailing list you are subscribed to is
maintained within your organisation, so if you do not wish to continue
receiving these bulletins you should contact your local IT manager. If
you do not know who that is, please send an email to auscert@auscert.org.au
and we will forward your request to the appropriate person.

NOTE: Third Party Rights
This security bulletin is provided as a service to AusCERT's members.  As
AusCERT did not write the document quoted above, AusCERT has had no control
over its content. The decision to follow or act on information or advice
contained in this security bulletin is the responsibility of each user or
organisation, and should be considered in accordance with your organisation's
site policies and procedures. AusCERT takes no responsibility for consequences
which may arise from following or acting on information or advice contained in
this security bulletin.

NOTE: This is only the original release of the security bulletin.  It may
not be updated when updates to the original are made.  If downloading at
a later date, it is recommended that the bulletin is retrieved directly
from the author's website to ensure that the information is still current.

Contact information for the authors of the original document is included
in the Security Bulletin above.  If you have any questions or need further
information, please contact them directly.

Previous advisories and external security bulletins can be retrieved from:

        https://www.auscert.org.au/bulletins/

===========================================================================
Australian Computer Emergency Response Team
The University of Queensland
Brisbane
Qld 4072

Internet Email: auscert@auscert.org.au
Facsimile:      (07) 3365 7031
Telephone:      (07) 3365 4417 (International: +61 7 3365 4417)
                AusCERT personnel answer during Queensland business hours
                which are GMT+10:00 (AEST).
                On call after hours for member emergencies only.
===========================================================================
-----BEGIN PGP SIGNATURE-----
Comment: http://www.auscert.org.au/render.html?it=1967

iQIVAwUBWl08F4x+lLeg9Ub1AQiNrw//W6h96pkic+HdcKFHVAGu53mAv8TZ/T3l
N5nbWSKE9t3QWCpN2hWxWKVXJk7rPRppydfpF/Qky4ZZOA/erMhLG25g9MEcwhyg
zQf+lnu11CKcW9M0l+TYZGQDzXb7FcdP48+yON6BfkfJmGGbPyFGzCsFrTUili+E
HY09gXhZn/+Ah/fkp9uKBtUQ5FR2WfvtutAB9lHR2bDs3bFRcBrD/7mYgazJhhza
S4oMEiXkAK+WkZVMFGpXJDhRYtgIqLyVoeXsbbOLMCCGuHc/7I1+7ftZAE86BYui
ZUZY/aqnKWWG4q4nrIkHsvd2L4+o3XhPoap2c2AMBBUTNSHfZHWSv+QpAsRiLOhX
+nVcl6Q/RfK3nOQyAL2cwhfERAzbUPNhTalN6Heh9dV3+O/GykcBuDaPTjMMpYBO
FVHo3UWgjazwhQ0f7U3PRmT2bwA48P20TUCyCMn4yN/F9dtjIxWypagueT1N2+/Q
c+IkREAXDUytEZPjLHgsVmKGHTHpDg89NKKoLrM0Z6HA+IxD7FCBLxswGB3a2lqf
7rQNVO5OyjNnBw/OOyz/+qLle/yLYp00GnD4UzzUXP2whIVDHFmx1N2nuuYwIuU5
lTHwhAYOgy7tbgeJD+XostWKPLNgmzj6Tvgf8SnlY7UHg7x+PJXkV4mEXDjBZLhm
l+BHXJUwhyc=
=XHfa
-----END PGP SIGNATURE-----